Debezium Releases Overview

Series

development

2.0

2022-09-16
Move to Java 11; new sink sinks; removal of deprecated code

latest stable

1.9

2022-09-23
Metrics improvements; Oracle ROWID data type support; Custom retriable error message support

Tested Versions

2.0 1.9
Java 11+ 11+
Kafka Connect 2.x, 3.x 1.x, 2.x, 3.x
MySQL Database: 5.7, 8.0.x
JDBC Driver: 8.0.29
Database: 5.7, 8.0.x
JDBC Driver: 8.0.28
MongoDB Database: 4.0, 4.2, 4.4, 5.0
Driver: 4.6.1
Database: 3.2, 3.4, 3.6, 4.0, 4.2, 4.4, 5.0
Driver: 4.3.3
PostgreSQL Database: 10, 11, 12, 13, 14
JDBC Driver: 42.4.1
Plug-ins: decoderbufs, pgoutput
Database: 10, 11, 12, 13, 14
JDBC Driver: 42.3.5
Plug-ins: decoderbufs, pgoutput
Oracle Database: 12c, 19c, 21c
JDBC Driver: 12.2.0.1, 19.8.0.0, 21.1.0.0, 21.3.0.0, 21.4.0.0, 21.5.0.0, 21.6.0.0
Database: 12c, 19c, 21c
JDBC Driver: 12.2.0.1, 19.8.0.0, 21.1.0.0
SQL Server Database: 2017, 2019
JDBC Driver: 10.2.1.jre8
Database: 2017, 2019
JDBC Driver: 9.4.1.jre8
Cassandra 3 Database: 3.11.12
JDBC Driver: 3.11.12
Database: 3.11.12
JDBC Driver: 3.11.12
Cassandra 4 Database: 4.0.2
JDBC Driver: 4.14.0
Database: 4.0.2
JDBC Driver: 4.14.0
Db2 Database: 11.5
JDBC Driver: 11.5.0.0
Database: 11.5
JDBC Driver: 11.5.0.0
Vitess Database: 12.0.x
JDBC Driver: 12.0.0*
* See the Vitess Connector documentation for limitations when using the connector with earlier Vitess versions
Database: 12.0.x
JDBC Driver: 12.0.0*
* See the Vitess Connector documentation for limitations when using the connector with earlier Vitess versions
The Debezium connectors have been tested with the versions of Java, Apache Kafka (Connect), and databases listed above. Testing is done using Linux containers. Specific Debezium connectors might also be compatible with other database versions not listed here.